Sâu mới đột nhập Linux qua ứng dụng PHP

  • 1.277

Các chuyên gia bảo mật ngày hôm qua đã cảnh báo người dùng về một sâu máy tính mới chuyên tấn công vào các hệ thống Linux bằng cách khai thác lỗ hổng bảo mật trong một ứng dụng PHP.

Ứng dụng bị sâu Mare.D lợi dụng khai thác ở đây là phần mềm mã nguồn mở hệ thống quản trị nội dung Mambo và thư viện PHP XML-RPC.

Nếu đột nhập thành công vào hệ thống sâu Mare.D có khả năng mở rất nhiều cổng sau - ví dụ như hai cổng "connectback shell" liên kết với máy chủ ở xa khác hay ba cổng sau cho phép tác giả phần mềm độc hại này có quyền truy cập và kiểm soát hệ thống thông qua kênh IRC.

"Sâu Mare.D được lập trình bằng ngôn ngữ C trên nền tảng ứng dụng lập trình GNU C," Gergely Erdelyi - chuyên gia nghiên cứu của hãng bảo mật F-Secure - cho biết.

Mare.D còn được trang bị khả năng tự động quét các lỗ hổng bảo mật khác trên hệ thống bị nhiễm và cài đặt các đoạn mã tự thực thi nhỏ khác phục vụ cho việc tải về các phần mềm độc hại khác.

Các lỗ hổng bảo mật trong Mambo và thư viện PHP XML-RPC đều được xếp vào mức "Cực kì nguy hiểm". Tuy nhiên, cho đến nay vẫn chưa có bản vá lỗi nào khắc phục. 

Cập nhật: 06/10/2016 Tổng hợp

Theo dõi cộng đồng Khampha.tech trên facebook